1. Xác thực tài khoản để có thể sử dụng đầy đủ chức năng của diễn đàn. Xem hướng dẫn
    Dismiss Notice

Lỗi 404 khi bật Use Full Friendly URLs

Thảo luận trong 'Installation & Upgrade Questions' bắt đầu bởi star.nyu, 10/9/13.

1votes
5/5, 1 vote

  1. Sieuchuoi

    Sieuchuoi New Member

    Bài viết:
    3
    Likes :
    0
    Cái này có áp dụng dc với 000webhost ko mấy bạn?
     
  2. dragondark9999

    dragondark9999 Member

    Bài viết:
    223
    Likes :
    38
    cái này là do tùy host, host mình áp dụng như thế nên chỉ coi thế nào
     
  3. cuong pham

    cuong pham Member

    Bài viết:
    392
    Likes :
    114
    các bạn nếu ko bật url friends lên đc thì backup file htaccess lại , rồi tạo file htaceess với nội dung như sau:
    Mã:
    #    Mod_security can interfere with uploading of content such as attachments. If you
    
    #    cannot attach files, remove the "#" from the lines below.
    
    #<IfModule mod_security.c>
    
    #    SecFilterEngine Off
    
    #    SecFilterScanPOST Off
    
    #</IfModule>
    
    
    
    ErrorDocument 401 default
    
    ErrorDocument 403 default
    
    ErrorDocument 404 default
    
    ErrorDocument 500 default
    
    
    
    <IfModule mod_rewrite.c>
    
        RewriteEngine On
    
    
    
        #    If you are having problems with the rewrite rules, remove the "#" from the
    
        #    line that begins "RewriteBase" below. You will also have to change the path
    
        #    of the rewrite to reflect the path to your XenForo installation.
    
        #RewriteBase /xenforo
    
    
    
        #    This line may be needed to enable WebDAV editing with PHP as a CGI.
    
        #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    
    
    
        RewriteCond %{REQUEST_FILENAME} -f [OR]
    
        RewriteCond %{REQUEST_FILENAME} -l [OR]
    
        RewriteCond %{REQUEST_FILENAME} -d
    
        RewriteRule ^.*$ - [NC,L]
    
        RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    
        RewriteRule ^.*$ index.php [NC,L]
    
    </IfModule>
     
  4. zoom360

    zoom360 Member

    Bài viết:
    392
    Likes :
    113
    Mình cũng bị khi xài host windows plesk panel, có ai biết cách fix giúp với
    Nội dung file .htacess
    Mã:
    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #    SecFilterEngine Off
    #    SecFilterScanPOST Off
    #</IfModule>
    
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    
    <IfModule mod_rewrite.c>
        RewriteEngine On
    
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        #RewriteBase /xenforo
    
        #    This line may be needed to enable WebDAV editing with PHP as a CGI.
        #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
    Đang dùng host windows của godaddy, Plesk Panel 11.5
    Link của site: http://vnnet.org lỗi 404 khi vào forum, member,...
     
  5. vanluong2608

    vanluong2608 Member

    Bài viết:
    261
    Likes :
    25
    hướng dẫn đi bác
     
  6. ThemeTrade

    ThemeTrade New Member

    Bài viết:
    17
    Likes :
    2
    mình thì khi bật Use Full Friendly URLs thì bấm vào RSS thì bị lỗi. là bị gì các bác?
     
  7. dacuoidhv

    dacuoidhv New Member

    Bài viết:
    54
    Likes :
    6
    .htacess bạn sao nguyên 1 bản ntn - sau đó đặt ngang hàng với thư mục data nhé - lỗi 404 hay xuất hiện khi ta sài vps hoặc hosting như stable host :))
     
    ThemeTrade thích bài này.
  8. ThemeTrade

    ThemeTrade New Member

    Bài viết:
    17
    Likes :
    2
    file .htaccess mình nguyên bản từ htaccess.txt và có test từ file .htaccess của diễn đàn khác (không bị lỗi trên) nhưng đều vẫn chưa khắc phục được.
     
  9. Sunflower

    Sunflower Member

    Bài viết:
    135
    Likes :
    75
    Bạn chạy VPS hay gì, nếu VPS thì bạn vào:
    /etc/httpd/conf => edit: httpd.conf, thêm cuối cùng:
    Mã:
    <VirtualHost *:80>
         ServerAdmin [email protected]
         DocumentRoot /var/www/domain.com/public_html
         ServerName www.domain.com
         ServerAlias domain.com
         ErrorLog /var/www/domain.com/error.log
         CustomLog /var/www/domain.com/requests.log common
         <Directory "/var/www/domain.com/public_html">
            Options Indexes FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
         </Directory>
    </VirtualHost>
     
    ThemeTrade thích bài này.
  10. ThemeTrade

    ThemeTrade New Member

    Bài viết:
    17
    Likes :
    2
    Cảm ơn sự trợ giúp nhiệt tình của bạn. Nhưng mình dùng nginx, file cấu hình trên dành cho apache rùi :(
     
  11. Sunflower

    Sunflower Member

    Bài viết:
    135
    Likes :
    75
    Bạn chỉnh sữa file .conf của virtual host mà bạn cấu hình domain sửa như sau:

    Tìm:
    Sửa thành:
    Hoặc nếu nằm ở public_html:
    Còn bạn /folder thì:
    Nếu bạn làm file.conf domain riêng thì:
    Rồi: sudo service nginx restart nhé./
     
    Last edited: 30/1/16
    ThemeTrade thích bài này.
  12. ThemeTrade

    ThemeTrade New Member

    Bài viết:
    17
    Likes :
    2
    Cảm ơn bạn Sunflower nhiều nhé, dựa vào thông tin của bạn mình đã fix thành công, và đây là thành quả:
    Site chính: http://diendan.suaphancung.com/
    Site RSS: http://diendan.suaphancung.com/dien-dan/sua-mainboard-laptop/index.rss

    tks Sunflower and Happy new year 2016 ;)
     
  13. nobita8x

    nobita8x New Member

    Bài viết:
    6
    Likes :
    0
    Mình cũng đang mày mò tập làm forum.

    Mình cũng bị trường hợp này, cách sửa đơn giản như sau :

    bạn vào Cpanel > file File Manager > public_html > htaccess.txt tải xuống,

    Mở htaccess.txt tìm dòng lệnh
    #RewriteBase /xenforo

    xóa chữ xenforo đi save lại, upload lại lên public_html đè vào file cũ.

    xong vào search engine optimisation ( SEO ) bật Use Full Friendly URLs, rồi vào hưởng thành quả xem :)

    Thành quả của mình đây : travelmapvn.net

    Chúc may mắn







     
comments powered by Disqus

Chia sẻ trang này

Đang tải...